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 Release Notes 
  
 
FILE:  E:\Nurse Courier 3 Editor\Release Notes\NC3Editor-Release-B.doc     KU   REV: 1.1 
DATE:  November 2005 
 
SUBJECT:  NC3 Editor Version 1.0.x Software Release Notes 
  
 
This document provides a release history of Nurse Courier 3 Editor Version 1.0 Software and 
its supporting software components. 
 
Nurse Courier 3 Editor Version 1.0.1 – Ganged Release 1 
 
Ganged Release 1 consists of the following software: 
 
Nurse Courier 3 Editor     V1.0.1  
Tel-Comm (SWTELCOMM)     V3.0.2 
Tel-Comm Configuration Utility (SWTCCFGU)  V1.0.0 
Tel-Terminal (SWTERMINAL)    V1.0.0 
Tel-Terminal Link for Tel-Comm (SWTERMTCAI) V1.0.0 
NC3 Editor Link for Tel-Comm (SWNC3TCAI)  V1.0.0 
 
 
Improvements in Nurse Courier 3 Editor Version 1.0.1 
 
Nurse Courier 3 Editor: 
NC Plus functionality is not affected if Station Info and/or Station Name of a Room Type in 
Room Configuration table is left blank. 
 
The options "Insert After" and "Insert Before" have been removed from the Public Address 
Configuration table. The remaining option "Delete" can be seen in the popup menu when right-
clicking on the leftmost cell of any row in the table (must have PA Circuits). 
 
In the Call-in/Public Address Assignment section, selecting more than one Zone will display 
only Room numbers assigned to the selected Zones.  
 
A Page Zone no longer remains inactive when a page is sent to the Zone. 
 
Rooms that are not assigned an MCC-6(T) Console (faulty Room programming) can no longer 
be uploaded. In addition, faulty Room programming is identified during validation.  
                                                                                                                                                                                   
In the Call-in/Public Address Assignment, the Console and Room tabs correctly display which 
Console a Room calls. 
 
A Zone can be configured to have the option none selected as the Default Callin Console. 
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A Zone can now be configured as strictly a Call-in Zone (with no boxes checked in the Zone 
Configuration table.) 
 
Performing a Page All or Facility Page All will no longer page Rooms that are meant to be  
excluded. (A Room is excluded by having the Use Room Paging flag unchecked in each Zone 
that the room is assigned to. The Use Room Paging flag is in the Zone Configuration table.)                    
 
Performing a Page All or Facility Page All will no longer page PA Circuits that are meant to be 
excluded. (A PA Circuit is excluded by having the Use Overhead Paging flag unchecked in 
each Zone that the PA Circuit is assigned to. The Use Overhead Paging flag is in the Zone 
Configuration table.) 
 
Upon installation, NC3 Editor automatically backs up the existing INI file before installing the 
new INI file. Backup files are named nce.bk0, nce.bk1, etc. Users who have been required by 
technical support to manually change the INI file in the past will need to transfer the 
previously-changed portions from the backup file to the new INI file. If so, please contact 
Telecor Technical Support.  
 
 
Known Issues & Work Arounds in Nurse Courier 3 Editor Version 1.0.1 Software 
 
Nurse Courier 3 Editor: 
1. Users who had created a Nurse Courier 3 Project using a version earlier than Nurse Courier 

3 Editor Version 1.0 Beta Release 7 may encounter the following errors when validating 
their project using a later Editor version: “Rooms assigned to Zone will be ignored,” “PA 
circuits assigned to Zone will be ignored,” etc.  

 
To resolve these errors: using either the Zone Wizard or the Zone Configuration Table, 
assign a specific role to each Zone, such as reporting to a Zone Light, Duty Station, or 
Annunciator Panel, or allowing for Room Paging or Overhead Paging.  

 
2. During uploading, Nurse Courier 3 Editor may upload the data for all configured Areas, 

even for Areas whose data has not been modified. This is a Known Issue, and will be 
addressed in a future release of Nurse Courier 3 Editor Software. This issue does not affect 
the operation of the T3-NC3 Controller. 

 
3. A bitmap loaded into Graphical View may cause sluggish dragging or a repainting of the 

bitmap and other graphical elements in the Graphical View Window. This behaviour has 
occurred on only a selected number of computers, suggesting that the problem may be 
caused by the hardware. This is a Known Issue, and may be addressed in a future release of 
Nurse Courier 3 Editor Software.  

 
4. If the total quantity of Rooms, Consoles, and Zones exceeds 99, dial numbers and names 

will not be automatically assigned to these items; in addition, if the total quantity of Areas 
exceeds nine, system numbers and names will not be automatically assigned to them.  

 

KevinUw2
Note
Completed set by KevinUw2

KevinUw2
Note
Completed set by KevinUw2

KevinUw2
Note
Completed set by KevinUw2

vlavrov
Note
Accepted set by vlavrov

vlavrov
Note
Accepted set by vlavrov

vlavrov
Note
Accepted set by vlavrov

MichaelPallett
Note
Accepted set by MichaelPallett



3 of 11 

Issue; future releases of Nurse Courier 3 Editor Software may provide enhanced numbering 
schemes for large-scale projects. 

 
 
Tel-Comm Configuration Utility 
1. When the user attempts to change the baud rate in Tel-Comm Configuration Utility, the 

error message “Cannot restart Tel-Comm” may appear. This has been discovered to occur 
on slow or very busy computers. This is because Tel-Comm Configuration Utility needs to 
restart the Tel-Comm service in order to use the new baud rate, but restarting this service is 
taking a long time because of the slow or busy computer. The solution is to check the status 
of the Tel-Comm service on the computer. Since Tel-Comm runs invisibly in the 
background, to verify whether Tel-Comm is running, you must access a feature called 
Windows® Services that’s available on your Windows® 2000 or XP operating system. To 
do this, complete the following steps: 

 
1. In Windows 2000: Click Start > Settings > Control Panel > Administrative Tools > 

Services. 
 

In Windows XP: Click Start > Control Panel. In the left column, under Control 
Panel, click Switch to Classic View. (If it says Switch to Category View, you are 
already in Classic view.) Click Administrative Tools > Services. 

 
•  Windows Services provides a list of all the “services” available on your system. 

 
2. Look for Tel-Comm in the list. The Status tab shows “Started” when Tel-Comm is 

running. 
 

If the Status tab shows “Starting,” wait a few minutes until it shows “Started.” 
(Click the Refresh button at the top of the Services window to refresh the page.) 

 
If the Status tab does not show “Started” or “Starting,” restart the PC. 

 
Note: In order to use Windows Services, you must have specific “privileges” assigned to 
your user account. Consult your Network Administrator if you cannot use Windows 
Services. 

 
Tel-Terminal  
1. When the baud rate is set to 19200 or lower, Tel-Terminal is sometimes unable to 

automatically reconnect when the Nurse Courier Controller restarts. When setting the baud 
rate in Tel-Comm Configuration Utility, the user should set the initial baud rate to 19200 
bps; once communications is established between the Tel-Comm PC and the Nurse Courier 
3 System, the user should set the baud rate to 38400 bps, the optimal speed for transferring 
data. Telecor recommends using this baud rate unless communication problems occur and 
the user is required to use a lower baud rate. If a lower baud rate is required, use 19200. If 
this is not possible, and 9600 or lower must be used, the user may have to manually 
reconnect to the Controller whenever it restarts. Do this by clicking the Connect button in 
Tel-Terminal and entering the Connect Code. 
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2. When using Tel-Terminal to connect to the Nurse Courier Controller, Tel-Comm 

automatically starts running. When Tel-Comm is running and successfully detects the 
Controller, in the Tel-Terminal window, the Connect button in the System Connection box 
is enabled. However, if Tel-Comm is for some reason not running or is unable to detect the 
Controller, Tel-Terminal does not display an error message to indicate to the user that it is 
unable to connect to the Controller (the Tel-Terminal screen sits idle). If this occurs, the 
user should either close the program and launch it again, or reconnect to Tel-Comm.  

 
To reconnect to Tel-Comm, complete the following steps: 

 
1. Click Options from the main menu. 
 
2. Select Re-connect to Tel-Comm. 
 

•  The Re-connect to Tel-Comm dialog box appears.  
 
3. Click Yes. 

 
•  The Connect to Tel-Comm dialog box appears. 

 
4. Select the My Tel-Comm is running on this computer option and click the Connect 

button. 
 

If after five attempts Tel-Terminal is still unable to connect to the Controller, this 
means that there is no communication between Tel-Comm and the Controller. Refer to 
the topic “Troubleshooting” in the Tel-Terminal help file for assistance in resolving the 
problem. 

 
 
Software Installation 
1. When performing the ganged installation, the following error message has been discovered 

to appear on some customer computers: “InstallShield Engine has encountered a problem 
and needs to close.” InstallShield then sends an error report and closes the program. If this 
occurs, please contact Telecor Technical Support for assistance in resolving the problem. 
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Nurse Courier 3 Editor Version 1.0 – Ganged Release 1 
 
Ganged Release 1 consists of the following software: 
 
Nurse Courier 3 Editor  Version 1.0  
Tel-Comm    Version 3.0 
Tel-Comm Configuration Utility Version 1.0 
NC3 Editor Link for Tel-Comm Version 1.0 
Tel-Terminal     Version 1.0 
Tel-Terminal Link for Tel-Comm Version 1.0 
 
 
New Features of Nurse Courier 3 Editor Version 1.0  
 
Nurse Courier 3 Editor: 
The Timed Autosave feature periodically saves your Nurse Courier 3 Project to a backup file, 
which can be recovered if the Editor exits abnormally or the computer fails. This feature is 
automatic. Upon launching the Editor application after an abnormal exit from the program, it 
will prompt you on whether you wish to recover the unsaved file. 
 
The Project tab in Global Settings provides three more fields for the user to record information 
about a Nurse Courier 3 Project, including “Contractor,” “Site,” and “Date/Time.” Information 
entered in these fields will be included in the Hardware Report. 
 
The Hardware Report records the date and time of when it was generated. 
 
Configuration Tables (except for the “STU/Room” Table) include an extra column “Additional 
Notes” for inputting extra information. This information will be included in the Hardware 
Report, but will not be uploaded to the T3-NC3 Controller. 
 
The Firmware version this Nurse Courier 3 Editor Version 1.0 is intended for is displayed in 
the splash screen when the program starts. This information can also be displayed by selecting 
Help > About Nurse Courier Editor when the program is open.  
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Tel-Terminal: 
A status icon on the Tel-Terminal screen indicates whether or not the PC is connected to the 
Controller. A green icon indicates connection, while a red icon indicates disconnection.   
 
Up to 500 Controller startup messages can be logged. In the previous version, the number of 
messages that could be logged was limited to 100. 
 
 
Improvements in Nurse Courier 3 Editor Version 1.0 
 
Nurse Courier 3 Editor: 
The Zone Wizard provides instructions on how to select multiple Public Address Circuits for a 
Zone. 
 
The first screen of the Room Type Wizard, which lists all Room Types that have been created, 
includes the ones created using the Room Type Configuration Table. 
 
The Zone Configuration Wizard no longer shows overlapping text. 
 
In the Hardware Report, STU numbers will consist of two numbers (i.e. “1.2”). The first 
number represents the System Number and the second number represents the STU number.  
 
The Editor no longer exits abnormally when a user deletes a Zone that has Public Address 
Circuits assigned to it. 
 
The Editor no longer generates Alarm calls for the dual callcord NC2-R2 Room Intercom 
Station. Only the NC1-R2A and NC2-R2A, which are equipped with Alarms, will generate 
Alarm calls. 
 
Faults occurring in the system (i.e. with a Controller, TBU, or power) will annunciate with one 
standard tone at the Console. Previously, each type of fault that occurred in the system 
annunciated at the Console with a different tone. 
 
When a KRA phone receives a call-in and is then hung up, the call-in rings back at the KRA 
phone every one minute (until the call-in is cancelled at the source). Previously, the call-in, if 
not cancelled at the source, rang immediately after the KRA phone was hung up. 
 
An STU port will not be allocated for a Zone unless devices (i.e. Zone Light, Duty Station, 
Annunciator Panel) have been assigned to that Zone. 
 
If an MCC-6(T) Console from one Area is moved to another Area that already has a Console 
and their CR-3 identification numbers are the same, the Editor will automatically change the 
CR-3 ID number for the Console that has been moved so that all CR-3  ID numbers remain 
unique. 
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The “Phone/Ext. Number” field in the Remote Telephone Configuration Table is enabled even 
when there is only one remote telephone in an Area. If no number is entered in this field, the 
T3-NC-KRA-1 is used. If a number is entered in this field, the T3-NC-KRA-2 is used. 
 
The term “Remote Telephones” is now used in the Editor so that it covers both wired and 
wireless telephones. This term replaces the previous term “Wireless Telephones.” 
 
In the Call-in tab in Global Settings, the sequence of colours shown for each Dome Light lamp 
pattern corresponds to the lamp colours on the NC1-L3 Dome Light. 
 
The Editor no longer exits abnormally when a Zone is assigned to a different Area. 
 
The Editor no longer exits abnormally when the user attempts to load a corrupt Nurse Courier 
3 Project file. 
 
A Room can be configured to call an MCC-6(T) Console in a different Area without having to 
be configured to call any other devices.  
 
A Room can be configured to call an MCC-6(T) Console in a different Area as well as Pocket 
Pagers and Remote Telephones. 
 
A Page Zone can include Public Address Circuits in a different Area. 
 
Tel-Comm/Tel-Comm Configuration Utility: 
Even if no COM port is selected for the PC using Tel-Comm Configuration Utility (Tel-Comm 
uses this port to communicate with the Nurse Courier 3 System), the user is still able to start 
Tel-Comm in Windows Services. No error messages will appear.  
 
 
Known Issues & Work Arounds in Nurse Courier 3 Editor Version 1.0 Software 
 
Nurse Courier 3 Editor: 
1. Users who had created a Nurse Courier 3 Project using a version earlier than Nurse 

Courier 3 Editor Version 1.0 Beta Release 7 may encounter the following errors when 
validating their project using a later Editor version: “Rooms assigned to Zone will be 
ignored,” “PA circuits assigned to Zone will be ignored,” etc.  

 
To resolve these errors: using either the Zone Wizard or the Zone Configuration Table, 
assign a specific role to each Zone, such as reporting to a Zone Light, Duty Station, or 
Annunciator Panel, or allowing for Room Paging or Overhead Paging.  

 
 
2. During uploading, Nurse Courier 3 Editor may upload the data for all configured Areas, 

even for Areas whose data has not been modified. This is a Known Issue, and will be 
addressed in a future release of Nurse Courier 3 Editor Software. This issue does not 
affect the operation of the T3-NC3 Controller. 
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3. A bitmap loaded into Graphical View may cause sluggish dragging or a repainting of the 
bitmap and other graphical elements in the Graphical View Window. This behaviour has 
occurred on only a selected number of computers, suggesting that the problem may be 
caused by the hardware. This is a Known Issue, and may be addressed in a future release 
of Nurse Courier 3 Editor Software.  

 
 
4. If the total quantity of Rooms, Consoles, and Zones exceeds 99, dial numbers and names 

will not be automatically assigned to these items; in addition, if the total quantity of Areas 
exceeds nine, system numbers and names will not be automatically assigned to them.  

 
To resolve this problem, the user must manually assign unique dial numbers, names, 
system numbers, etc. Use the System Configuration Tables to do this. This is a Known 
Issue; future releases of Nurse Courier 3 Editor Software may provide enhanced 
numbering schemes for large-scale projects. 

 
 
5. In Nurse Courier 3 Editor, the Page All and Facility Page All functions can be enabled by 

assigning dial numbers to them.1 When enabled, the Page All and Facility Page All 
functions will page all devices in the facility equipped with speakers, including Room 
Stations. These two paging functions, however, are not intended to page Room Stations 
that have otherwise been excluded from public address zones. This is a Known Issue, and 
will be addressed in a future maintenance release of Nurse Courier 3 Editor Software.  

 
If you want to activate the Page All or Facility Page All function but exclude Room 
Stations from being paged, the workaround is to create a Zone that is used specifically for 
paging. Once this Zone is created, you can use the Call-in/Public Address Assignment 
feature in the Editor to manually assign the required devices to this Zone (i.e. Public 
Address Circuits or Consoles). Instructions are provided below to assist you in creating a 
Zone that will be used specifically for the Page All/Facility Page All function: 

 
1. Bring up the Zone Configuration Table and create a new Zone. 
 

a) In the Zone Name field, name the Zone “Page All” or “Facility Page All.” 
 
b) In the PA Dial Number field, assign a dial number to this Zone. 

 
c) Select the Use Overhead Paging box. 
 

2. Bring up the Call-in/Public Address Assignment dialog box and select the Zones 
tab. 

 
a) In the Available Zones box, select the Zone you created and click the > button 

to include the Zone in the Selected Zones box. 

                                                           
1 The “Page All” feature is enabled in the Area Configuration Table and the “Facility Page All” feature is enabled in Global Settings > 
Public Address tab. 
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b) In the bottom left corner, in the Filter box, select All and check off the boxes of 
the devices you want to have displayed in the Available Stations and Public 
Address box (i.e. Public Address). 

 
c) In the Available Stations and Public Address box, select the devices to be 

included in this Zone.  
 

d) Click the > button to include these devices in the Zone. 
 
3. Select File > Save to save your Nurse Courier 3 Project. 

 
 
Tel-Comm Configuration Utility 
6. When the user attempts to change the baud rate in Tel-Comm Configuration Utility, the 

error message “Cannot restart Tel-Comm” may appear. This has been discovered to occur 
on slow or very busy computers. This is because Tel-Comm Configuration Utility needs 
to restart the Tel-Comm service in order to use the new baud rate, but restarting this 
service is taking a long time because of the slow or busy computer. The solution is to 
check the status of the Tel-Comm service on the computer. Since Tel-Comm runs 
invisibly in the background, to verify whether Tel-Comm is running, you must access a 
feature called Windows® Services that’s available on your Windows® 2000 or XP 
operating system. To do this, complete the following steps: 

 
3. In Windows 2000: Click Start > Settings > Control Panel > Administrative Tools > 

Services. 
 

In Windows XP: Click Start > Control Panel. In the left column, under Control 
Panel, click Switch to Classic View. (If it says Switch to Category View, you are 
already in Classic view.) Click Administrative Tools > Services. 

 
•  Windows Services provides a list of all the “services” available on your system. 

 
4. Look for Tel-Comm in the list. The Status tab shows “Started” when Tel-Comm is 

running. 
 

If the Status tab shows “Starting,” wait a few minutes until it shows “Started.” 
(Click the Refresh button at the top of the Services window to refresh the page.) 

 
If the Status tab does not show “Started” or “Starting,” restart the PC. 

 
In order to use Windows Services, you must have specific “privileges” assigned to your 
user account. Consult your Network Administrator if you cannot use Windows Services. 
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Tel-Terminal  
7. When the baud rate is set to 19200 or lower, Tel-Terminal is sometimes unable to 

automatically reconnect when the Nurse Courier Controller restarts. When setting the 
baud rate in Tel-Comm Configuration Utility, the user should set the initial baud rate to 
19200 bps; once communications is established between the Tel-Comm PC and the Nurse 
Courier 3 System, the user should set the baud rate to 38400 bps, the optimal speed for 
transferring data. Telecor recommends using this baud rate unless communication 
problems occur and the user is required to use a lower baud rate. If a lower baud rate is 
required, use 19200. If this is not possible, and 9600 or lower must be used, the user may 
have to manually reconnect to the Controller whenever it restarts. Do this by clicking the 
Connect button in Tel-Terminal and entering the Connect Code. 

 
 
8. When using Tel-Terminal to connect to the Nurse Courier Controller, Tel-Comm 

automatically starts running. When Tel-Comm is running and successfully detects the 
Controller, in the Tel-Terminal window, the Connect button in the System Connection box 
is enabled. However, if Tel-Comm is for some reason not running or is unable to detect 
the Controller, Tel-Terminal does not display an error message to indicate to the user that 
it is unable to connect to the Controller (the Tel-Terminal screen sits idle). If this occurs, 
the user should either close the program and launch it again, or reconnect to Tel-Comm.  

 
To reconnect to Tel-Comm, complete the following steps: 

 
5. Click Options from the main menu. 
 
6. Select Re-connect to Tel-Comm. 
 

•  The Re-connect to Tel-Comm dialog box appears.  
 
7. Click Yes. 

 
•  The Connect to Tel-Comm dialog box appears. 

 
8. Select the My Tel-Comm is running on this computer option and click the Connect 

button. 
 

If after five attempts Tel-Terminal is still unable to connect to the Controller, this 
means that there is no communication between Tel-Comm and the Controller. Refer to 
the topic “Troubleshooting” in the Tel-Terminal help file for assistance in resolving the 
problem. 

 
 
Software Installation 
9. When performing the ganged installation, the following error message has been discovered 

to appear on some customer computers: “InstallShield Engine has encountered a problem 
and needs to close.” InstallShield then sends an error report and closes the program. If this 
occurs, please contact Telecor Technical Support for assistance in resolving the problem. 
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10. During the Tel-Comm installation, you will be prompted to create a Tel-Comm remote 
access password (the installation requires you to enter a password). For some customers, 
however, the installation program fails at this point. This is a Known Issue, and will be 
addressed in a future maintenance release of Nurse Courier 3 Editor Software.  

 
The installation program seems to fail in situations where a version of Tel-Comm already 
exists on the computer. Therefore, the workaround is to remove this version of Tel-Comm 
from the computer and then go through the Tel-Comm installation again. To do this, 
complete the following steps: 

 
1. Select Start > Control Panel, and then double-click Add/Remove Programs. 
 
2. In the Currently installed programs box, select Tel-Comm from the list, and then 

click the Remove button. 
 
3. In the Add/Remove Programs confirmation box, select Yes. 

 
Note: In some cases, even attempting to remove the earlier version of Tel-Comm from the 
computer will cause a crash. If this occurs, proceed to Step 4 and 5 regardless.   
 
4. Restart the computer. 

 
5. Run the Nurse Courier 3 Editor installation program again to install Tel-Comm. For 

instructions on how to install Nurse Courier 3 Editor Software, refer to the Nurse 
Courier 3 Editor Installation Guide. 

 
 
 

© Copyright 2005 by Telecor Incorporated.  All rights reserved.  No part of this publication may be reproduced in any form or by any means without the 
prior written permission of Telecor Inc.  Telecor Inc. makes no representation of warranties with respect to this document.  Further, Telecor reserves the 
right to make changes in the specifications of the product described in this document any time without notice, and without obligation of Telecor Inc. to notify 
any person of such revisions or changes. 




